Wie ich einen Bug in Google Chrome fand

Update (16.09.2014): Der Fehler ist offenbar nicht auf Chrome beschränkt: Meine Tests haben im Internet Explorer das selbe Phänomen hervorgerufen. Offensichtlich liegt es daran, wie ein Link aufgerufen wird. Das weiter zu verfolgen, übersteigt jetzt leider meine Fähigkeiten.

Update (13.09.2014): Ich habe noch etwas getestet: Wenn man „Nach Updates suchen“ in CCleaner anklickt und Chrome damit startet, tritt der Fehler ebenfalls auf. Ein Browserstart über den Link-Klick in Dropbox hingegen gibt kein Problem.

Jeder Internet-Browser bietet inzwischen die Möglichkeit, Uploads per Drag & Drop zu erledigen – wenn die Website dafür eingerichtet ist. Ich benutze Google Chrome und der kann das. Eigentlich. Doof nur, dass es eben nicht immer funktioniert.

Inzwischen weiß ich aber, woran es lag und falls Ihr auch mit solchen Problemen zu kämpfen habt, ist dieser Beitrag die Lösung. Okay, es muss nicht immer helfen, aber bei ähnlichen Szenarien dürfte es bei der Fehlersuche dienlich sein.

 

Fehlerbeschreibung

Manchmal lassen sich Dateien nicht per Drag & Drop hochladen. Außerdem funktionieren Aufrufe von außen nicht mehr: Wenn ich in einem Programm einen Button anklicke, der eine Website öffnen soll, passiert nichts in Chrome (als Standard-Browser eingestellt).

 

Versuche der Problemlösung

Der Fehler tritt nur sporadisch auf, weshalb ich lange herumprobieren musste. Updates, Registry-Reinigungen, Neuinstallationen – nichts half. Es funktionierte eine Weile und ich dachte, ich hätte den Fehler endlich ausgebügelt, plötzlich ging es wieder nicht.

 

Der Lösung ganz nah

Heute Morgen (bei mir gegen 12 mittags) ging ich an den Rechner und startete – wie ich das fast immer tue – KeePass. Ich suchte in der Rubrik „Social Media“ den Facebook-Eintrag, klickte – wie ich das fast immer tue – auf den Button „Login-Link öffnen“ und da traf mich ein Geistesblitz…

Ich tue das fast immer so! Manchmal starte ich Chrome aber auch ganz normal mit Klick auf das Icon in meinem Dock. Also stellte ich meine Theorie auf die Probe: Ich loggte mich bei Facebook ein und zog ein Bild auf das „Beitrag posten“-Feld: BÄM! Drag & Drop geht nicht.

Ich klickte den „Statistiken zeigen“-Button in cFosSpeed an und: Es geht nicht. Wie ich erwartet es hatte. Nun also die Gegenprobe…

 

Problem gelöst

Ich beende Chrome, starte über das Dock, logge mich mit KeePass ein und ziehe testweise ein Bild rein: Drag & Drop geht. Der Aufruf aus cFosSpeed endet ebenfalls positiv. Also jetzt der ultimative Test: Chrome beenden und Chrome per KeePass-Button starten.

Wie zu erwarten war: Drag & Drop funktionierte nicht und auch der Aufruf aus cFosSpeed ging ins Nirvana. Der Hammer, wie einfach sich manche Dinge manchmal lösen lassen. Man muss halt nur erstmal drauf kommen.

Als Konsequenz lasse ich nun Chrome automatisch starten und umschiffe so das Problem.

Ein Kommentar zu diesem Artikel

Name: Tore  |  Datum: 7. September 2014  |  Zeit: 15:27

Interessanter Ansatz. Jetzt wäre es noch interessant zu wissen, liegt es an keepass oder an allen von extern geöffneten links?
Ein weiterer Fall für den Netzblogr. ;-)

Mich trifft das jetzt zum Glück nicht so, da ich alle Seiten nur direkt aufrufe und dann per Hotkey Keepass aus dem Tray ziehe.
Aber dennoch gut zu wissen, was passieren könnt, wenn… :-)

Hinterlasse einen Kommentar





Alle mit * gekennzeichneten Felder müssen ausgefüllt werden. Die eMail-Adresse wird nicht offen dargestellt.

Ich erlaube mir, reine Werbeeinträge oder persönliche Beleidigungen zu löschen. Anonyme Kommentare werden generell nicht mehr freigeschaltet: Ich schreibe hier als reale Person und darf erwarten, dass jeder zu der Meinung steht, die er äußert.